Accueil > 3 Problèmes > [Résolu] panier qui se vide sans raison

[Résolu] panier qui se vide sans raison

Mon problème.

Sur ma base de test, alors que j’ai réussi une première fois à créer un panier avec plusieurs produits et à aller jusqu’au paiement, je n’arrive plus à utiliser le panier.

J’arrive à ajouter un article au panier mais quand je veux en ajouter un autre, le panier se vide systématiquement.

Par ailleurs je constate que le pavé « derniers articles consulté » ne se met plus à jour.

Ma solution.

Comme la boutique sur laquelle je fait mes test est une boutique basée sur la base de données de ma boutique en production, je suis allé jeter un coup d’oeil, via phpMyAdmin dans les tables de ma base.

Dans la table des paramètres de la boutique, j’ai constaté que la table ps_configuration contenait le champ CANONICAL_URL et que la valeur dans ce champ était celle de mon site de prod. Le changement du nom de domaine ne se fait évidement pas automatiquement dans ce cas…

Dans le BO, j’ai trouvé l’endroit où l’on modifie ce paramètre : c’est dans modules / tools / URL canonique

Je ne suis pas sûr que ce soit ce changement qui empêche le panier de se vider mais en tout cas tout fonctionne maintenant avec le bon paramètre et quel que soit le navigateur utilisé (IE, Firefox). Si vous avez rencontré le même problème et l’avez, vous aussi, résolu de cette manière, merci de me laisser un commentaire.

  1. bavoil
    septembre 24, 2010 à 4:11

    j’ai le meme soucis pour passer commande sur un site de pièces mécaniques, mais c’est récent ca ne me le faisait pas lors des précédentes commandes maintenant mon panier prend qu’un seul article et se vide automatiquement quand je vais le consulter HELP!!!merci

  2. décembre 1, 2010 à 8:07

    j’ai le même soucis sur IE, l’url canonique semble bonne .. je ne trouve pas d’ou ça vient.

  3. juillet 27, 2012 à 6:21

    Cela peut également être du à l’option « géolocalisation » activée. Parfois ça déconne et le module empêche le remplissage du panier en pensant que l’user vient d’un pays interdit.

    Espérant que ça sera aidant pour certains =)

  4. fid
    septembre 12, 2012 à 10:30

    Bonjour, ayant eu le problème tout récemment, je confirme que c’était l’option « géolocalisation » dans mon cas. En la désactivant, ça fonctionne.

  5. Sam
    octobre 27, 2012 à 5:32

    Pour moi la solution c’est que j’ai décocher URLs simplifiées dans /Panneau d’administration Outils/ Générateurs

  6. mimi
    décembre 2, 2012 à 12:51

    Bonjour, j’ai le même problème avec chrome (sur firefox ça fonctionne…). Je ne comprends pas encore d’où ça vient.

  7. Mesnil
    mars 5, 2013 à 10:45

    Idem, cela fonctionne sans la géolocalisation ! Merci beaucoup pour cette astuce

  8. Mika
    novembre 28, 2015 à 10:05

    Moi j’ai résolu le problème (panier qui restait vide) en « désactivant le module mod_security d’Apache » dans Préférences > Seo & URL.

  1. No trackbacks yet.

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :